[V2/V3] Autobilling Interruption
Incident Report for Y42
Resolved
This incident has been resolved.
Posted May 03, 2024 - 12:28 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 03, 2024 - 12:24 CEST
Investigating
We're investigating an issue within our Autobilling API. Users may encounter the error message "There was an error retrieving your billing data." Rest assured, our team is actively working on resolving this issue. We apologize for any inconvenience caused and appreciate your patience.
Posted May 03, 2024 - 11:43 CEST
This incident affected: Webapp.